Corinth Corinth

Forum

Suche
Forum » Ticket to Ride - the Digital Game - English » New compatible with old version?
Anzeigen: Heutige Nachrichten 
  
VerfasserThema
sheilainpa1
Junior Member

Nachrichten: 1
Registriert:
April 2015
New compatible with old version? Sun, 29 November 2015 06:52
My friend doesn't want to update her TtR and I already did.....we can't find each other anymore to play on line. Are the versions not compatible?
      
    
Vorheriges Thema:Scoring craziness
Nächstes Thema:TTR on laptop closing program at end of game
Gehen Sie zum Forum: